The code is saved as a parameter by printing with command "echo", to read it in markdown code mode is a little difficult, the screen shot of formated code is here:
@Not-Oles #119 The obvious error is that the part of assigning target disks:
d-i partman-auto/disk string /dev/sda /dev/sdb
"sda" or "sdb" devices are corresponded to SCSI interface hdds, the NVME interface ssds' names of your server are nvme0n1 and nvme1n1, so I need to fix this bug first to make sure the program should find the correct raid 0 disk devices.
@lchecho #128 那你私信我,把 tg 发来,我们好好看看问题怎么解决
支持!一直在用旧的重装脚本 试试新的
经测试,目标机器网络配置经过脚本的自动修复(原来的掩码 255.255.255.255 明显错误)后已无问题,但特别挑源,机器在德国,目前仅测试过:
http://ftp.hosteurope.de/mirror/ftp.debian.org/debian/http://mirror.de.leaseweb.net/debian/两个源可以通过源有效性检测,Debian 官方源:deb.debian.org 无法使用,且安装过程中,连接 security.debian.org 安装安全更新也会因无法连接而报错,必须要在 VNC 里回车确认才能跳过。
IPv6 部分在安装重启进入系统后能自动配好。
该问题由于过于特殊,可能是由于商家上游某些错误的网络配置造成的,故不再为其做特殊处理,欧洲很多 oneman 小商家都有这样的毛病。
@leitbogioro #133
感谢大佬,问题解决,dd成功
@lchecho #134 我刚剁了个垃圾大王virmach的荷兰阿姆斯特丹小鸡,2.5G内存那个,xtom机房,i/o和网络挺不错,重装也非常快,也没有ip配置不对,连接源不通的毛病,你要不试试virmach的冷门地区机房?日本就算了,人多挤爆,经常 offline,还要初装费

https://virmach.com/vps-price-match-refugee-offers/
@lchecho #134 我感觉可以,剁手实证,年付21.88,2年付41.14那款:

棒棒!

@Not-Oles #121 Hello sir, here are the parts of raid 0 partition recipe in my code:
[[ "$setRaid" == "0" ]] && FormatDisk=`echo -e "d-i partman-md/confirm boolean true d-i partman-md/confirm_nooverwrite boolean true d-i partman-basicfilesystems/no_swap boolean false d-i partman/mount_style select label d-i partman-auto/method string raid d-i partman-auto/disk string "$IncDisk" /dev/sdb d-i partman-auto-raid/recipe string \ 1 2 0 ext4 /boot "$IncDisk"1#/dev/sdb1 . \ 0 2 0 ext4 / "$IncDisk"2#/dev/sdb2 . d-i partman-auto/expert_recipe string multiraid :: \ 400 100 400 raid \\$bootable{ } \\$primary{ } method{ raid } . \ 100 200 -1 raid \\$primary{ } method{ raid } . d-i mdadm/boot_degraded boolean true"`The code is saved as a parameter by printing with command "echo", to read it in markdown code mode is a little difficult, the screen shot of formated code is here:

@Not-Oles #119 The obvious error is that the part of assigning target disks:
d-i partman-auto/disk string /dev/sda /dev/sdb"sda" or "sdb" devices are corresponded to SCSI interface hdds, the NVME interface ssds' names of your server are nvme0n1 and nvme1n1, so I need to fix this bug first to make sure the program should find the correct raid 0 disk devices.
@Not-Oles #112 Sir, could you please give me a root permission? I found that I can't use vim, and can't use "apt install vim -y" to install it.