logo NodeSeekbeta

史上最强,支持 Debian 12 raid 0 Ubuntu 24.04(测试中);512MB 内存安装 AlmaLinux/RockyLinux;CentOS 9 Fedora 39 AlpineLinux Kali Linux Windows 重装程序功能更新、bug反馈贴(长期更新)

  • @camellia #485 换一下镜像源

  • mark

  • 强 支持大佬 ac08

  • 好帖,必须支持

  • cloud.linode.com的5刀机器,自带的debian 12系统,想DD一下,也是debian 12,出现错误:

    SeaBIOS (version rel-1.16.0-0-gd239552ce?22-prebuilt.gemu.org )

    iPXE (http://ipxe.org) 00:04.0 CA00 PCI2.10 PnP PMM+3FF90D90+3FEF0D90 CA00

    Booting from ROM...
    Welcome to GRUB!

    error: variable 'prefix' isn't set.

    github提了有截图的issues

  • @renkx #495

    1. 重新启动后,在 VNC 会看到,机器卡在一个界面,提示“error: variable `prefix' isn't set.”。

    2. 不用担心,这是因为 Linode 自带的系统,需要依赖后台提供的 grub2 程序引导到原系统启动才行,一键重装后的纯净系统,由于是用硬盘上自己的 grub 启动的,并非再由 Linode 后台的 grub2 引导启动,所以 Linode 的 grub2 引导纯净系统会报错。

    官方的引导程序,还可以使 Linode 支持控制台进行备份、快照或缩扩容。因为我们安装好的全新系统里,使用自带的 grub 引导启动,所以会导致以上 Linode 提供的自定功能就会全都失效。若要完整实现Linode控制台全部功能,请参见《重装Debian之一:适用于Linode的Debian重装指南》中“3. 制作boot盘并完成重装”章节,自行完成设置。

    1. 打开 Linode Web 后台,先将机器强制关机。

    2. 确认机器运行状态变成“Offline”,点击“Configurations”功能区,点击“Edit”,编辑该机器的引导参数。

    3. 将“Boot Settings”→“Select a Kernel”下原来的“grub2”,修改为“Direct Disk”。

    4. 拖到最后,将“Auto-configure networking”打开。

    5. 核查一下以上两个项目是否设置正确,确认无误,接着点击“Save Changes”。

    6. 从对话框退出,最后,点击“Power On”,不出意外,等待一会后,直到后面板机器状态变成“RUNNING”,且持续 ping 能重新看到结果,说明机器已经从自带的 grub2 启动,我们的纯净系统安装成功了。你可以按照执行脚本时设置的端口、密码,以 root 用户登录到系统。

    参考链接:

    重装Debian之一:适用于Linode的Debian重装指南

    https://global.lian-lian.tel/code/linux/debian-reinstall-guide-part1-a-virgin-debian-for-linode-server/

    https://www.linode.com/docs/products/compute/compute-instances/guides/install-a-custom-distribution/

  • @zxxx #496 果然可以了,🍗奉上,谢谢🙏

  • @zxxx #496

    按照这个方法确实可以进系统了,但是会出现启动特别慢的情况,原因可以看下这个 github的issues回答

    截图可以看到,启动的时候,networking启动超时了,但是最后还是可以ssh进入系统的,不知道啥情况。


    解决了,把 auto eth0 改为 allow-hotplug eth0就可以了,也不知道是不是dd有问题造成的。。。

    具体可以看上面的github的issues链接

  • @renkx #498

    机器带 IPv6 吗?

你好啊,陌生人!

我的朋友,看起来你是新来的,如果想参与到讨论中,点击下面的按钮!

📈用户数目📈

目前论坛共有72280位seeker

🎉欢迎新用户🎉