logo NodeSeekbeta

komari与cf access / cf tunnel的配合 遇到302 moved和其他问题

在komari内部开启cf隧道和我在docker里开有区别吗
改下原标题 tunnel并不是问题。

客户端里komari-agent遇到以下错误,有的能连上,有的显示离线了。
琢磨是不是komari面板里启动隧道会不会好呢

Error uploading basic info: invalid v2 JSON-RPC response: invalid character '<' 
looking for beginning of value, body: "<!DOCTYPE html>\n<html>\n  <head>\n    <title>
	
Failed to connect to WebSocket: 302 Moved Temporarily
	
v2 WebSocket endpoint failed (302 Moved Temporarily), falling back to v1 
	until this connection is lost

尝试了这个参数/opt/komari/agent --help 理论上是可以通过cf access的auto auth?(不是bypass) 但错误依旧

/opt/komari/agent --help
Flags:
      --auto-discovery string            Auto discovery key for the agent
      --cf-access-client-id string       Cloudflare Access Client ID
      --cf-access-client-secret string   Cloudflare Access Client Secret
  • 没什么区别吧?
    只是 Docker 你要注意容器 IP 的问题
    xhj007

  • 实际上自己开更好

  • @Shikanoko #1 嗯 在同一个docker-compose里 用komari:25774就行

  • 习惯cf仪表盘就用官方的

  • 个人感觉没啥区别

  • @solaireh3 #6 我不知道里面有这个 只用过老版本。就自己写近docker-compose启动了。不过楼上说的对,自己搞的更可控些。
    现在这问题好像跟waf拦截规则有关。

  • @ele #7 我也是docker装的cloudflared,跟komari放一个网络就行了

你好啊,陌生人!

我的朋友,看起来你是新来的,如果想参与到讨论中,点击下面的按钮!

📈用户数目📈

目前论坛共有72259位seeker

🎉欢迎新用户🎉