@梦影 #0 在1G硬盘上会失败(alpine和debian都会,可以到reboot,但重启后好像就死了,2G硬盘的后装的都先好了,然后还等了一个小时,还不行),同主机2G硬盘就没问题(占用360M左右) Bin佬的1G硬盘可以成功,就是系统就占了660M,装不了什么了 阿里云抢占式1G硬盘
@梦影 #45 专门建了一个实例测试,问题依旧吧,1G硬盘仍然重装不了,然后你这个也不像Bin佬的可以看安装进度,只能看阿里云后台CPU不动了去试试了,然后也多等了半小时依然不行 update: 截止19:58:06依然不行,重启后四十多分钟了,估计还是在哪里因磁盘空间不足挂了吧,已销毁实例 ps: 正常阿里云用脚本重装十分钟左右,最慢二十分钟内肯定可以,已重装几十次的经验
@梦影 #45 看了一下你处理小硬盘的代码,感觉没什么用,在没空间的时候执行balance会失败甚至导致空间溢出(极端小环境用compress-force可能更好) 这是小众需求,其实不支持也无所谓,实在想就按我的老套路,加盘迁移就完了,反正btrfs很方便 在2G硬盘及以上都能成功重装
@梦影 #0 在1G硬盘上会失败(alpine和debian都会,可以到reboot,但重启后好像就死了,2G硬盘的后装的都先好了,然后还等了一个小时,还不行),同主机2G硬盘就没问题(占用360M左右)
Bin佬的1G硬盘可以成功,就是系统就占了660M,装不了什么了
阿里云抢占式1G硬盘
@梦影 #0 通过2G硬盘安装好后用btrfs特性添加1G硬盘删除2G硬盘迁移完成
迁移时发现使用的数据块有1.2G+,这也可能是1G硬盘无法安装的原因,需要回收已分配数据块
@KqnxZqvs #42 收到,我排查一下
@seiuneko #26


整完活,挺香,1G小硬盘跑起来
ps:拉满等级是15吧,越大压缩越强
强
@梦影 #45 专门建了一个实例测试,问题依旧吧,1G硬盘仍然重装不了,然后你这个也不像Bin佬的可以看安装进度,只能看阿里云后台CPU不动了去试试了,然后也多等了半小时依然不行

update:
截止19:58:06依然不行,重启后四十多分钟了,估计还是在哪里因磁盘空间不足挂了吧,已销毁实例
ps:
正常阿里云用脚本重装十分钟左右,最慢二十分钟内肯定可以,已重装几十次的经验
@梦影 #45 看了一下你处理小硬盘的代码,感觉没什么用,在没空间的时候执行balance会失败甚至导致空间溢出(极端小环境用compress-force可能更好)
这是小众需求,其实不支持也无所谓,实在想就按我的老套路,加盘迁移就完了,反正btrfs很方便
在2G硬盘及以上都能成功重装
@KqnxZqvs #48
感谢,我换成compress-force试试
@bin456789 #16 能不能支持esd格式啊?