请教楼主: 备份时自动备份原始 /etc/nginx/sites-available/default,退出后可一键恢复。 那么如果nginx配置不是在etc目录,比如宝塔怎么办,脚本的逻辑是什么呢? 另外,我阿里云机器备份成功后出来的是局域网地址 --- ✅ 备份完成!【请在新服务器恢复完后再退出脚本】!! --- 在新服务器上,输入源服务器的IP或域名将会自动下载以下备份文件: 数据包: http://172.19.51.140:8889/docker_data.tar.gz 启动脚本: http://172.19.51.140:8889/docker_run.sh 把内网ip换成公网后,好像不行。 另外docker_data.tar.gz文件好像是空的,只有45B大小,是不是备份失败了?
@ceocok #149 发布于2025/8/29 08:29:42 @jjaibb #146 必须在,不在就无法下载呗。没考虑宝塔。一般情况备份不会失败,你这情况有点像 建议内置轻量web服务器,且端口可以自定义,就完美了。 nginx等常用的大多数人已经安装,且路径千差百异,造成脚本兼容不佳。
这个方便
这个真的太强了!
bd
感谢,研究研究
太牛了
请教楼主:
那么如果nginx配置不是在etc目录,比如宝塔怎么办,脚本的逻辑是什么呢?
另外,我阿里云机器备份成功后出来的是局域网地址
把内网ip换成公网后,好像不行。
另外docker_data.tar.gz文件好像是空的,只有45B大小,是不是备份失败了?
@Venompool #55
感谢分享
bd
@jjaibb #146 必须在,不在就无法下载呗。没考虑宝塔。一般情况备份不会失败,你这情况有点像
建议内置轻量web服务器,且端口可以自定义,就完美了。
nginx等常用的大多数人已经安装,且路径千差百异,造成脚本兼容不佳。