logo NodeSeekbeta

CloudFlare SaaS(自定义主机名) 回源 Tunnel(隧道) 手把手图文教程

定义两个域名:
主域名:apply.dpdns.org (DNS托管在第三方平台)
次域名:vpc.us.kg (DNS托管在CloudFlare)

原理流程:
SaaS(自定义主机名) -> SaaS源服务器 -> Tunnel(隧道)

用到的三个域名:
自定义主机名:tunnel.apply.dpdns.org
源服务器:tunnel-saas.vpc.us.kg
Tunnel(隧道):(隧道ID).cfargotunnel.com

在正式操作之前需要先在Cloudflare把主域名:apply.dpdns.org 添加到Cloudflare(不用修改域名DNS)
注意:只是添加域名到Cloudflare 不用修改域名DNS!!! 只在Cloudflare操作添加就可以

首先在Cloudflare -> Zero Trust -> 创建隧道
image
image
image
复制令牌配置Tunnel隧道客户端
image
继续完成Tunnel隧道创建 添加Tunnel主机名
PS:这里如果看不到你要选择的域 apply.dpdns.org 说明你没有把域添加到Cloudflare(不用修改DNS!!!)
image
复制隧道ID Tunnel隧道CNAME域名: (隧道ID).cfargotunnel.com
image

添加默认回退域(不然自定义源服务器会失败)
image
image

源服务器:tunnel-saas.vpc.us.kg 解析到 Tunnel隧道CNAME域名: (隧道ID).cfargotunnel.com
image
自定义主机名:tunnel.apply.dpdns.org 解析到 源服务器域名
image
添加自定义主机名 完成域名添加TXT验证
image
image
完成以后检查有效状态
image
按照流程走不出意外成功访问
image

自定义主机名:tunnel.apply.dpdns.org
都可以试试是不是成功访问!(家里云的ARM 没绑定域名默认状态就是403)

有些人私信和评论区留言说多域名自定义主机名失败 自定义主机名回到了默认回退域
我后补5张图说明是可以正常多域名自定义主机名自定义回源对应的服务器的
如果因为HTTPS失败重新编辑下默认回退源然后等待一会在试试
image
image
image
image
image

123
  • xhj020 xhj006

  • bd,学习

  • 这样不用在本地服务器做任何设置就可以是吗?那这样的话,避免了在本机安装CF tunnel?

  • @imsnail #3

    使用cloudflare Tunnel
    本地肯定要安装cloudflare Tunnel客户端
    image
    我这一步就是在1panel上配置令牌安装cloudflare Tunnel客户端

  • 图没了

  • 奇怪的设置有增加了,
    我是有ipv6,套了个cf,再saas接入

  • 这样搞有啥用

  • @kyaarin #7

    我的哪吒监控一样的

    自定义主机名 -> SaaS源服务器 -> AAAA(IPv6源站)

  • @dreamren #8

    有需求的自然有用
    没需求的就不用折腾

    我使用CloudFlare Tunnel相当于用来内网穿透
    腾讯云上海轻量直接反代没备案会被拦截

    使用CloudFlare Tunnel就不会被拦截

123

你好啊,陌生人!

我的朋友,看起来你是新来的,如果想参与到讨论中,点击下面的按钮!

📈用户数目📈

目前论坛共有72269位seeker

🎉欢迎新用户🎉