logo NodeSeekbeta

自建NAT64服务器,原生ipv6访问ipv4,便宜鸡拉免费鸡,将白嫖进行到底

  • 楼主牛x,自建NAT64 xhj003 xhj003 xhj003 鸡腿奉上

  • 便宜鸡拉免费鸡,100ms延时拉成200ms
    ac01

  • @云上拾荒者 #78 感谢答疑,换成不同子网下确实解决了问题1,nat64服务自测是正常了,原本的v6出口也能正常输出了。但是问题2,即dns64的客户端部署在另一台纯v6机器上的,现在是v6可以正常curl了,但是v4还是不行,Couldn't connect to server,用dig +short ipv4only.arpa测试也是只能返回v4地址,没有v6。我用纯v6机器随机ping那个nat64服务端随机96位的ipv6地址,发现除了第一包icmp失败或者等待很长时间意外,后面竟然也能通,这至少说明nat64应该是正常的,现在找不到头绪了

  • 支持一下 说不定以后用到了呢

  • @duanzhang #83 你这个看起来像是没有用unbound DNS,用的还是机器原本的DNS查询。

    你试试nslookup ipv4only.arpa ::1,先确认用本机Unbound查询,能拿到dns64地址。

    把Unbound设成默认DNS跟你的系统和网络管理器都有关系,所以在原帖里面就没有展开说了。很多系统的/etc/resolve.conf是系统自动生成的,网络一重启内容就会被覆盖。

    用resolved的话,你要改/etc/systemd/resolved.conf并重启resolved服务。

    安装了别的网络管理器的话,查查看你的网络管理器是怎么设默认DNS的

  • 绑定

  • @云上拾荒者 #85
    是的,即使指定本地地址也没有生效,;; Got SERVFAIL reply from ::1
    Server: ::1
    Address: ::1#53

    ** server can't find ipv4only.arpa: SERVFAIL,始终报这个错,但可以ping通对方96子网的随机ip。

  • @duanzhang #87 你的dns设置有点问题。我试过了配置良好的Unbound解析是没有问题的。

    image

    你对比一下unbound config看看哪里出问题了

    server:
    
      module-config: "dns64 iterator"
    
      dns64-prefix: 2401:****:****::/96
    
      do-not-query-localhost: yes
    
    forward-zone:
    
      name: "."
    
      forward-addr: 2400:3200::1@53
    
  • 我用wireguard来实现

  • nat64好像在alpine下运行报错,localhost:/opt/nat64# ls
    nat64
    localhost:/opt/nat64# ./nat64
    -sh: ./nat64: not found
    localhost:/opt/nat64# sh nat64
    nat64: line 0: syntax error: unterminated quoted string
    localhost:/opt/nat64# bash nat64
    nat64: nat64: cannot execute binary file
    alpine是新dd的系统,不知道是不是缺什么依赖导致这个报错,旧版和github的1.01好像都是这个报错。试过在debian12系统上尝试1.01的可以运行。

你好啊,陌生人!

我的朋友,看起来你是新来的,如果想参与到讨论中,点击下面的按钮!

📈用户数目📈

目前论坛共有72280位seeker

🎉欢迎新用户🎉