@luluby612 #22 应该是你启动的名称跟脚本不一样,脚本里的叫 blackbox-exporter,所以不是脚本的问题 还有可以看看端口占用情况,以及 prometheus.yml 有没有写对 (我这几天都超级晚睡,所以就先不跟啦)
Blackbox Exporter 服务端和监控端都要安装吗? 我报这个错误 err="parsing YAML file /etc/prometheus/prometheus.yml: yaml: line 38: did not find expected key" 第38行是 - job_name: 'Instance 1' 是服务端也要安装Blackbox Exporter吗?
牛逼,顶!
@Bene #20 谢谢
@luluby612 #22
应该是你启动的名称跟脚本不一样,脚本里的叫 blackbox-exporter,所以不是脚本的问题
还有可以看看端口占用情况,以及 prometheus.yml 有没有写对
(我这几天都超级晚睡,所以就先不跟啦)
太有毅力啦
@Bene #23 谢谢,已经搞定,误认为所有的Exporter配置文件都要填在一个文件,现在分开就可以了
Blackbox Exporter 服务端和监控端都要安装吗?
我报这个错误 err="parsing YAML file /etc/prometheus/prometheus.yml: yaml: line 38: did not find expected key"
第38行是 - job_name: 'Instance 1'
是服务端也要安装Blackbox Exporter吗?
@CM #26
或许是缩进问题?然后可以用双引号包裹看看
完了...又有新想法了...
不错
貌似太新的grafana和Prometheus不太适配?




这样又能查询到了!
已解决,原因是数据库没选到。
